Page 2 of 2

Re: LibreOffice 4.0 Released

PostPosted: 21 Mar 2013, 14:09
by Kellemora
I hear ya Yogi! I opened a whole new can of worms yesterday and today. Looks like I'll have to give in and go with Win7 after all.

That Acer Aspire ONE 722 that came with Win7, I partitioned and installed Debian 6, which runs just fine.
Debi wanted XP on it. I made a partition, installed XP, CRASH and BURN.
OK, so I changed the SATA from AHCI to IDE to get XP to install.
It installed and ran OK, except for one major problem. Acer has no AMD XP drivers for AHCI, which means the rest of the system does not work. Also, no drivers for the network, sound and a few other things.

Now what kills me is that I have XP on other machines, just as new, but I have not checked, maybe they are running in IDE mode. But they all work with sound and internet just fine.
Thankfully, there is NO UEFI on this machine!

I'm wondering if perhaps I install it in Virtual Box they way I did on another machine if that will get it to working? Doubtful if it's a driver issue. But I know my other computers all have Sata Drives.

Oh well, not a problem I want you to worry about. Whatever it is, it will be over my head anyhow.

TTUL
Gary

Re: LibreOffice 4.0 Released

PostPosted: 21 Mar 2013, 15:11
by Yogi
Windows 7 has a fallback mode at installation time. You can install to Windows XP instead of Windows 7. I don't know of anyone who actually did that, but I'd imagine that all the appropriate drivers would be available on the install CD should you go that route.

Putting XP on a virtual machine might just work. The virtual drivers are not the standard ones, and they interface with the host hardware via the VM software. As far as XP knows, the virtual world is the only world.

No, I don't work for Microsoft, but I can highly recommend Windows 7. I think Microsoft knew all along that this was going to be the last OS of it's kind and they put a lot of effort into making it a classic. I doubt that it will attain the status of Windows XP, but Windows 7 is probably the best OS that Microsoft ever produced. The transition from XP to Win7 isn't that difficult, albeit there will be a learning curve.

Regarding UEFI ... I have some first hand experience with it now. You may have read elsewhere that I converted my main machine from 32 bit to 64 by replacing the motherboard. Actually, I paid good money for somebody else to do the grunt work. The new mobo has UEFI built in. My installer put Vista, Windows 7, and Ubuntu 12.10 on that machine. Each has it's own hard drive. Ubuntu has GRUB installed on it's own drive and can see all three systems. The Microsoft MBR is on it's own drive and only sees Windows products. I thought there might be a UEFI problem when I could not install the video drivers into Ubuntu, but that was not the case. I made a procedural error and UEFI never interfered.

It turns out that UEFI only has some bearing on those systems with Windows 8 installed. At this point in time Windows 8 is the only OS in the world to have digitally signed keys attached. UEFI checks those keys before it allows you to boot, and thus stops anything else from working - both good and bad. As it turns out UEFI can be disabled via BIOS. You get the standard gloom and doom warnings, but it can be disabled. So, all the rumors that I've heard about UEFI are based on misinformation and ignorance. There are problems to be sure, but not so much with UEFI as with the OS's and drivers you try to install on said systems. As is the case in any other environment, know the rules and follow them for best results.

Re: LibreOffice 4.0 Released

PostPosted: 22 Mar 2013, 10:09
by Kellemora
Hi Yogi - With XP ending, I have tried very hard to get Win7 to work, and it just keeps failing at every corner.

After more hours than I can count, I finally got Win7 to See the hardwired LAN when hardwired, and be able to access all of the shared folders and open them.

However, I cannot get a folder on the Win7 machine to Share.

Any machine that tries to connect TO the Win7 machine, sees the machine, but it will not accept the password to open it.
Most other machines, you can open a machine, but when you try to open a folder, if password protected, THEN it asks for the password.

The only reason I need Windows at all is for the frau to play her Big Fish games, and the hundreds we have on CD's. Almost all of the CD versions will play in WINE, but because of DRM's none of the Big Fish games will, even if we re-register them.

I've read every single help file on Win7 networking that Mickey$oft and hundreds of 3rd party providers have produced.
And from the comments I see on-line; apparently only a small select handful have got Win7 networking even partially working, and then it is only occasionally.

How I finally got our LAN to partially work with Win7 was to change it to WORK. After I discovered HOME only works on Win7 to Win7 machines. I have the CORRECT Workgroup and passwords, but it makes no difference.

In the process of getting the wired LAN working, the WIFI connection was lost. It is apparently impossible to go from the WiFi LAN connection via the router to another LAN on the system. And I have not yet figured out how to set-up the machine if I go to Pantera's to use their WiFi.

Win7 only lets you have ONE connection at a time. And it is a day long fiasco to change from one LAN to another.
If I change to HOME to connect to the WiFi, then I cannot get to the WORK LAN.
If I change all the set-up parameters to allow connection to the WiFi from the WORK LAN, I also have to change the WiFi set-up to accept connects from the WORK LAN, then no one else can connect to the WiFi.

Under Ubuntu, Mint Maya and Debian, I have NONE of the above problems.
I can connect using WiFi on its LAN, then connect to the Workgroup LAN or LAN's as needed. No problems in seeing or sharing folders.

If I'm at Pantera's and want to connect to our Critique Groups LAN that we all belong to. Everyone running XP or Linux has no problem doing so. NO ONE running Win7 can join the Critique Groups LAN and the Pantera's WiFi at the same time.
Win7 is the reason we have now gone to using DropBox to exchange files between us.

I'm wondering what the H companies do that have Accounting on one LAN, Sales on another LAN, etc. How are they doing that on salesmen's Win7 machines using WiFi?

FWIW - I did a check on my desktop computers to see what the SATA settings were, since I do have XP running on all of them, and in Virtual Box. I had never changed them from the factory settings. And even though the drives are all 500 gig SATA drives. When I checked, all of them are running in IDE mode. I guess this is why XP worked.
But on the newest laptop, there are no XP drivers for networking, SATA ahci or sound. I guess XP is just to old to have the necessary drivers for the new hardware and Acer made the Aspire ONE 722 to work with Win7, not XP. They do have some drivers for Intel CPU's but the 722 is an AMD CPU machine.

FWIW: Many of the posts showing how to set up the networking, and especially now about sharing folders, must be for some version of Win7 other than Home Premium, as none of those boxes or setting are available on my installed version. The pictures shown on the Mickey$oft website, don't even come close to the images of the boxes I see, when following their directions to the letter.

The more I try messing with Win7, the more I HATE Mickey$oft. It is thousands of times harder to do anything on it, than it is on even the most awkward of Linux Distro's..........

TTUL
Gary

Re: LibreOffice 4.0 Released

PostPosted: 22 Mar 2013, 11:36
by Yogi
My solution to all the above is to turn off WiFi - I've been tempted to totally uninstall it for all the trouble it causes. I have three LANs here, one wired and two wireless, and never had a problem switching between them. That is true for all my Linux machines as well as Windows. I used to use a Linksys and then a Cisco network manager but found that I could do more by directly accessing my router via a browser. So I uninstalled the managers too. As an aside, when I migrated to Windows 7 I went for the Ultimate version. It doesn't get any better than that. Not that it's perfect, but it's all that can be had in a Win7 machine.

Yes, only one network connection is allowed at a time via Windows 7, but I don't know of any other OS that allows for simultaneous networks unless you are running a domain or workgroup server*. You can also do it with multiple Network adapters, but I don't know if your Home edition can handle that.

Windows 7 Home Groups (libraries) were intended to solve network file sharing problems. The issue there is that it's peer to peer and not all the computers on my LAN are Windows 7 based. So I don't use Home Groups either. All the computers here have Public folders that can be enabled if we need to share anything over the LAN. My (Linux based) NAS has an FTP server function built in. If I need to share things with remote clients, that is what I would use. My web hosting service also provides such a service and disk space so that I can share files there as well.

I don't think my comments will be of much help to your particular situation, but you should know that it's not impossible to do what you need to do. :mrgreen:


* Check this out. I think it's an explanation of why you are having network problems: http://www.tomshardware.com/forum/30862 ... oup-server

Re: LibreOffice 4.0 Released

PostPosted: 23 Mar 2013, 12:22
by Kellemora
Hi Yogi
Well, I broke the install. I attempted to add firefox from a .deb and something was missing. This causes Synaptic to give an error message and close. I finally fixed that part, so Synaptic now works. However, although the LAN is up and running just fine, when I connect to the internet, I get one page, then the network goes down.

For me, rather than trying to figure out what all I messed up. I'll take the easy route and just reformat and reinstall Debian.
It worked fine before I messed with it.

Odd thing though, I do have both Iceweasel and Firefox running on three desktop computers with no problems.
At first I was thinking that maybe Iceweasel was 32 bit and firefox 64, which is why there was no conflict.
But the About on each shows they are 64 bit versions. So why it failed is anybodies guess.
A repository entry won't let me access the key. It times out every try. I checked on another machine and the website is not down. This is what led me to find out my network crashes after the first page load.
Then of course, I now get Kernel Panic from the Network Manager.
It worked before I tried installing the firefox-mozilla-build.deb package.

FWIW: I carried the little laptop down to the house, within range of the WiFi and it connected to the WiFi, without my doing anything. But as before, no access to the Workgroup, unless I plug in the hard-wired LAN, then the Workgroup is available.

I can reinstall the whole OS faster than trying to figure out what went wrong.
I consider it a learning experience too. The more I have to install everything on Debian, the better I will remember it. For a week anyhow, then as usual, will forget everything, hi hi....

TTUL
Gary